071234567891011121314151617181920212223242526272829303109

スポンサーサイト

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。
【 --/--/-- (--) 】 スポンサー広告 | TB(-) | CM(-)

PAT(オーバーローディング)。

今日は集中力があるので、PATも学んでみる。

【条件】 2811Aで内部ローカル172.16.1.0/24を内部グローバル200.1.1.1に変換。



2811B
2811B#show run
!
hostname 2811B
!
interface Serial0/1/0
ip address 10.1.1.2 255.255.255.0
no ip directed-broadcast
!
ip route 200.1.1.0 255.255.255.0 10.1.1.1
ip route 172.16.1.0 255.255.255.0 10.1.1.1
ip classless
no ip http server
no ip http secure-server

line vty 0 4
password todd2
login
line vty 5 1180
password todd2
login

2811A
2811A#show run
hostname 2811A
!
interface FastEthernet0/1
ip address 172.16.1.1 255.255.255.0
no ip directed-broadcast
ip nat inside
!
interface Serial0/1/0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
ip nat outside
clockrate 64000
!
ip classless
no ip http server
no ip http secure-server
ip nat pool Test2 200.1.1.1 200.1.1.1 netmask 255.255.255.0
ip nat inside source list 1 pool Test2 overload

!
access-list 1 permit 172.16.1.0 0.0.0.255

hostA
172.16.1.2 /24
hostB
172.16.1.3 /24

昨日散々悩んだPAT。ダイナミックNATと赤字の部分が違う・・・だけ!?
某サイトでは、インターフェース名指定と書いてあったんだが、それだとコマンドが完成されない。
poolコマンドを使用し、変換範囲は1つだけなので、入力200.1.1.1のみ。
あとは同じようにpool名を指定して、overloadと打つだけ。



ほんとにこれだけでいいの?(汗


2811A#show ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 200.1.1.1:1723 172.16.1.2:1723 10.1.1.2:80 10.1.1.2:80
icmp 200.1.1.1:1723 172.16.1.3:1723 10.1.1.2:80 10.1.1.2:80

!?

ポート番号一緒だけど・・・。シミュレータだとこれでOKみたいな感じになってる。
あれ?でも同一IP使うのだから、ポート番号が違わないとダメなんじゃないの???

・・・微妙だ。
【 2010/08/19 (Thu) 】 CCNA (640-816J) | TB(0) | CM(0)

ダイナミックNAT(復習)

忘れてしまいそうなので、復習。

【条件】 2811Aで内部ローカル172.16.1.0/24を内部グローバル200.1.1.1~200.1.1.10に変換。



2811B
2811B#show run
!
hostname 2811B
!
interface Serial0/1/0
ip address 10.1.1.2 255.255.255.0
no ip directed-broadcast
!
ip route 200.1.1.0 255.255.255.0 10.1.1.1
ip route 172.16.1.0 255.255.255.0 10.1.1.1
ip classless
no ip http server
no ip http secure-server

line vty 0 4
password todd2
login
line vty 5 1180
password todd2
login

2811A
2811A#show run
hostname 2811A
!
interface FastEthernet0/1
ip address 172.16.1.1 255.255.255.0
no ip directed-broadcast
ip nat inside
!
interface Serial0/1/0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
ip nat outside
clockrate 64000
!
ip classless
no ip http server
no ip http secure-server
ip nat pool Test 200.1.1.1 200.1.1.10 netmask 255.255.255.0
ip nat inside source list 1 pool Test
!
access-list 1 permit 172.16.1.0 0.0.0.255

hostA
172.16.1.2 /24
hostB
172.16.1.3 /24
hostC
172.16.1.4 /24

確認は、2811Aでdebug ip nat 実行した状態で、各ホストから2811Bにtelnet。
その後 show ip nat translations実行。

2811A#
8 19 21:01:59.640: NAT*: s=172.16.1.4->200.1.1.3, d=10.1.1.2 [1]
8 19 21:01:59.640: NAT*: s=null->200.1.1.3, d=172.16.1.4 [1]
8 19 21:02:08.687: NAT*: s=172.16.1.3->200.1.1.4, d=10.1.1.2 [1]
8 19 21:02:08.687: NAT*: s=null->200.1.1.4, d=172.16.1.3 [1]
8 19 21:02:17.156: NAT*: s=172.16.1.2->200.1.1.1, d=10.1.1.2 [1]
8 19 21:02:17.156: NAT*: s=null->200.1.1.1, d=172.16.1.2 [1]

2811A#show ip nat translations
Pro Inside global Inside local Outside local Outside global
--- 200.1.1.3 172.16.1.4 --- ---
--- 200.1.1.4 172.16.1.3 --- ---
--- 200.1.1.1 172.16.1.2 --- ---

一応2811Bでshow users実行。

2811B#show users
Line User Host(s) Idle Location
0 con 0 idle 00:00:00
2 vty 0 idle 00:00:38 200.1.1.3
3 vty 1 idle 00:00:29 200.1.1.4
* 4 vty 2 idle 00:00:21 200.1.1.1

200.1.1.1~200.1.1.10の中で3ホスト分アドレス変換し、アクセスしていることが確認できる。




これでも問題ないよね?誰か先生降臨してくれないかな(´・ω・`)
【 2010/08/19 (Thu) 】 CCNA (640-816J) | TB(0) | CM(0)

スタティックNAT,ダイナミックNAT。

仕事の疲れか、最近帰宅してから勉強に集中できない
今日は1時間だけ...と始めたNATのお勉強。完全に抜け出せなくなって気づいたら3時間経ってた・・・。

memo...

・ スタティックNAT
 ① ip nat inside source static 内部ローカル 外部グローバル
  変換するローカルアドレスとグローバルアドレスの組み合わせを決めてあげる。

 ② ip nat inside / ip nat outside
   LAN側/WAN側のそれぞれのインターフェースにnatを適用してあげる。

・ ダイナミックNAT
 ① ip nat pool プール名 開始IPアドレス 終了IPアドレス netmask サブネットマスク
   ある範囲内のアドレスで変換を行うので、その範囲poolを決めてあげる。

 ② access-list 番号 permit 送信元IPアドレス ワイルドカードマスク
   上記で設定したpoolのアドレスを使用できる内部ローカルアドレスを設定する。
   (/24ローカルアドレス全てで利用を可能にする場合、/24ネットワークアドレスとワイルドカード 0.0.0.255)

 ③ip nat inside source list 番号 pool プール名
   上記二つの条件の組み合わせを決定する。何番のlistとなんという名前のpoolを使うか。

...end

だんだんコマンド細かくなってきたぞ
パラメーター増えると覚えられない

オーバーローディング(PAT)の設定もシミュレータ上はさっくりできたが、
ホストPCやスイッチ,ルータ等全ての機器の設定を最初から全て自分で構築してみたら失敗した。

もうだめだ集中できねー。・゚・(ノД`)・゚・。
寝ます...Zzz
【 2010/08/18 (Wed) 】 CCNA (640-816J) | TB(0) | CM(0)

VLAN 設定の謎。

構成図が載せられないので何とも言えないかもしれないが、
下線部分がなぜこのような解答になるのか、さっぱりわからない。

【問題】
CESARスイッチにVLAN 10、20及び30を設定
■F/0 7ポートをVLAN 10に設定
■F/0 4ポートをVLAN 20に設定
■F/0 1ポートをVLAN 30に設定
■F/0 5ポートをトランクに設定
■CESARスイッチのデフォルトVLANに1.1.1.2/24のIPアドレスを設定し、スイッチの管理に使用
■CESARスイッチのデフォルトゲートウェイに1.1.1.1 255.255.255.0のIPアドレスを設定


【シミュの解答】
CEASAR>enable
CESAR#conf t
CESAR(config)#interface Vlan 10  ← ?
CESAR(config-if)#interface Vlan 20 ← ?
CESAR(config-if)#interface Vlan 30  ← ?
CESAR(config-if)#interface FastEthernet 0/7
CESAR(config-if)#switchport mode access
CESAR(config-if)#switchport access vlan 10
CESAR(config-if)#interface FastEthernet 0/4
CESAR(config-if)#switchport mode access
CESAR(config-if)#switchport access vlan 20
CESAR(config-if)#interface FastEthernet 0/1
CESAR(config-if)#switchport mode access
CESAR(config-if)#switchport access vlan 30
CESAR(config-if)#interface FastEthernet 0/5
CESAR(config-if)#switchport mode trunk
CESAR(config-if)#interface Vlan 1
CESAR(config-if)#ip address 1.1.1.2 255.255.255.0
CESAR(config-if)#no shutdown
CESAR(config-if)#exit
CESAR(config)#ip default-gateway 1.1.1.1
CESAR(config)#exit
CESAR#copy running-config startup-config

vlan 10 name ○○ とかのコマンドはいいの?
show vlan 叩いてもVLAN 10とか表示されてこないのに・・・。
しかも模範解答でVLAN0010って・・・意味不明だ。そんな入力ルールあったっけ??

ほかの問題でも、課題がVLAN間の通信確認なのに、
何も接続されていないインターフェースにVLAN割り振らないと減点とか
そこにトランクの設定入れろ
とか、これじゃ満点取れません...orz

vlan database に任意のVLAN登録して、各インターフェースに割り当て。

switchport mode access or switchport mode trunk
switchport access VLAN ○

これじゃダメなのか。これで問題なく通信できるぞ。

トランクは、switchport trunk encapsulation dot1qと打つ場合があるけど
これは接続する機械によって、いる/いらないがあるのかな?

スイッチ間でVLAN情報を交換する場合は、VTPの設定をすればいい。
ドメイン名を設定し忘れると情報来ないので注意でしょうか。

余計なVLANの設定やdescriptionを削除しないと減点?
テストで使えるかわかりませんが、show runで確認したほうがよさげですね。

(show interface だとスイッチはポート多くて見にくい・・・)

ただただメモメモ....
【 2010/07/29 (Thu) 】 CCNA (640-816J) | TB(0) | CM(0)

猛暑日は[カフェ入って勉強]に限る。

モチベーションが高いうちに、第4章・第5章を駆け抜けた。

TFTPでIOSをバックアップしたり復元したり、telnetでルータにログインしたりと
このあたりは日常業務で馴染みがあるのでスイスイ。

第5章では、ルーティングプロトコル(EIGRPとOSPF)の設定を行った。

memo.

・ AS番号は統一。

・ OSPFのプロセス番号は、同一ネットワーク内で複数のAS番号を使用しない限り気にしない?

・ エリアの範囲を限定するのは、networkコマンド上のワイルドカード。

・ インターフェースのpriority上げても、DR選出されねぇーーーーーorz

任意のインターフェースのpriorityを上げる

全インターフェースshutdown

全インターフェースno shutdown

DR再選出

これは間違いなのか...orz

・ DR/BDR選出時、priority同じ場合はルータIDが判断材料となる。

end...

明日は仕事の空き時間に勉強できない為、第6章を少し進めて終わるだろう。
【 2010/07/22 (Thu) 】 CCNA (640-816J) | TB(0) | CM(0)


上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。